WP Marketing » Tag: security - Recent Posts http://wpmarketing.org/forum/tags/security Wordpress for Internet and Affiliate Marketing en-US Tue, 15 Jul 2014 08:50:42 +0000 http://bbpress.org/?v=1.0.2 <![CDATA[Search]]> q http://wpmarketing.org/forum/search.php hanadaddy on "Running wp-admin over SSL and mixed content issue" http://wpmarketing.org/forum/topic/running-wp-admin-over-ssl-and-mixed-content-issue#post-275 Sun, 30 Jan 2011 20:13:11 +0000 hanadaddy 275@http://wpmarketing.org/forum/ <p>I really appreciate of your thoughtfulness on using the image locally instead of removing the RSS widget. Thank you. Enjoy the plugin. </p> nitaonline on "Running wp-admin over SSL and mixed content issue" http://wpmarketing.org/forum/topic/running-wp-admin-over-ssl-and-mixed-content-issue#post-274 Sun, 30 Jan 2011 19:30:50 +0000 nitaonline 274@http://wpmarketing.org/forum/ <p>Thank you for your quick reply!</p> <p>Honestly, I thought briefly about that but I felt it a bit impolite to whack out your feed, so what I chose to do instead was to move a copy of that image to my server and point to that in the <code>hana-code-insert/wpmarketing_feed.php</code> file; that route doesn't affect the feed content being displayed over SSL.</p> <p>However, I appreciate your tip for a more fundamental quick fix, and will apply that instead, now.</p> <p>Thanks again! </p> hanadaddy on "Running wp-admin over SSL and mixed content issue" http://wpmarketing.org/forum/topic/running-wp-admin-over-ssl-and-mixed-content-issue#post-272 Sun, 30 Jan 2011 19:18:20 +0000 hanadaddy 272@http://wpmarketing.org/forum/ <p>Hello<br /> Thank you for using my plugin.</p> <p>You can always disable the widget by editing the plugin file <code>hana-code-insert/hana-code-insert.php</code></p> <p>Just comment out the last line like below.</p> <pre> //require_once("wpmarketing_feed.php"); </pre> <p>Thank you. </p> nitaonline on "Running wp-admin over SSL and mixed content issue" http://wpmarketing.org/forum/topic/running-wp-admin-over-ssl-and-mixed-content-issue#post-271 Sun, 30 Jan 2011 06:01:22 +0000 nitaonline 271@http://wpmarketing.org/forum/ <p>Hi, first of all: kudos for the Hana Code Insert Plugin. In our case, our members need to fill out professional details at registration, and since access over WiFi hotspots isn't always secure, we've decided to run all of the wp-admin backend over SSL (with a cert and static IP of course). It's not because of "commercial" trust but because of security, for both visiting members and yours truly.</p> <p>Functionally speaking, the Hana Code Insert Plugin doesn't protest running over SSL - it works perfectly fine. However, because of the calls to remote non-https assets (i.e. the WP Marketing / RSS icon within the widget) the browser protests, because of ye olde mixed content problem, as far as I can tell mostly due to the RSS widget of the plugin on the wp-admin main page. And calls to a https version of that same image fail, arguably because SSL isn't available (or simply blocked) on the WP Marketing site server.</p> <p>To be sure, this is the image that's giving me a bit of trouble:</p> <p><img src="http://wpmarketing.org/image/wpmarketing_rss.png" alt="The WP Marketing RSS icon" title="The WP Marketing RSS icon" /></p> <p>Of course it's trivial to solve it by downloading that image and putting it on the site, and then point to it with a webroot-relative pointer so as to switch to whichever protocol requires it, but I thought it'd be more polite to flag it here before hacking out something which may serve another purpose (e.g. metrics gathering, although I'm not sure if that's really useful in the main wp-admin settings page, all the more with the toggle to hide/show the widget there).</p> <p>So, I wonder if it's possible to address that either by serving such remote content on request via https, or drop the static assets in the plugin folder and pull them from there (with a sensible function i.e. to pick the right protocol) so as to avoid this little but pesky problem... </p> <p>Thanks in advance for looking into it (and helping to make the internet a better place!) </p> Babar on "Videos are not displaying soruce amazon s3" http://wpmarketing.org/forum/topic/videos-are-not-displaying-soruce-amazon-s3#post-122 Sat, 06 Feb 2010 05:52:02 +0000 Babar 122@http://wpmarketing.org/forum/ <p>I tried normal method to embed video with hana flv player and its working fine.</p> <p>Now I'm trying to load the video through hana flv player and with amazon s3 url genrator.<br /> Actually i'm using that method for restricting visitor they can only view and should not download the video.</p> <p>here you can see<br /> <a href="http://becominghmc.com/demo/health-questionnaire/" rel="nofollow">http://becominghmc.com/demo/health-questionnaire/</a></p> <p>Error I'm getting : 200,stream not found, Netstream.play.streamnotfound, clip: '[]</p> <p>Your support actually is great thanks in Advance :)</p> <p>Regareds,<br /> Babar </p> Babar on "Videos are not displaying soruce amazon s3" http://wpmarketing.org/forum/topic/videos-are-not-displaying-soruce-amazon-s3#post-110 Thu, 21 Jan 2010 17:04:34 +0000 Babar 110@http://wpmarketing.org/forum/ <p>I was using folder name " hana-flv-player.2.4" that's why video not displaying i just renamed the folder to hana-flv-player" and its working fine now.</p> <p>Great support Hana :) </p> hanadaddy on "Videos are not displaying soruce amazon s3" http://wpmarketing.org/forum/topic/videos-are-not-displaying-soruce-amazon-s3#post-108 Wed, 20 Jan 2010 14:02:30 +0000 hanadaddy 108@http://wpmarketing.org/forum/ <p>Hello! I see that below javascript file is not properly loaded.</p> <p>If you see the html source code, you will file below script tag to load necessary javascript file. </p> <pre> &lt;script src='http://becominghmc.com/wp-content/plugins/hana-flv-player/osflv/AC_RunActiveContent.js' language='javascript'&gt;&lt;/script&gt; </pre> <p>But if you manually try to load the URL (<code><a href="http://becominghmc.com/wp-content/plugins/hana-flv-player/osflv/AC_RunActiveContent.js" rel="nofollow">http://becominghmc.com/wp-content/plugins/hana-flv-player/osflv/AC_RunActiveContent.js</a></code>) in the browser, you get nothing. You should be able to see the javascript file in order to make this work. </p> <p>My guess is that you are using some kind of Wordpress security plugin that prevents javascript file to run when it is located under the plugins folder.</p> <p>Either you should disable this security plugin or copy the <code>AC_RunActiveContent.js</code> file out of the plugins folder , maybe into Wordpress root path so that you can access it by URL <code><a href="http://becominghmc.com/AC_RunActiveContent.js" rel="nofollow">http://becominghmc.com/AC_RunActiveContent.js</a></code>. </p> <p>Then add below lines into your theme's <code>header.php</code> file.</p> <pre> &lt;script src='http://becominghmc.com/AC_RunActiveContent.js' language='javascript'&gt;&lt;/script&gt; </pre> Babar on "Videos are not displaying soruce amazon s3" http://wpmarketing.org/forum/topic/videos-are-not-displaying-soruce-amazon-s3#post-106 Wed, 20 Jan 2010 10:51:02 +0000 Babar 106@http://wpmarketing.org/forum/ <p>Plugin version : Hana Flv Player V2.4.2</p> <p>Here is the URL where i'm using your sample code for displaying the video: <a href="http://becominghmc.com/?p=1" rel="nofollow">http://becominghmc.com/?p=1</a></p> <p>Here is the code which i'm using in the post :</p> <p>[hana-flv-player<br /> video="https://becoming.s3.amazonaws.com/teaser.flv"<br /> width="400"<br /> height="320"<br /> description="Sarah is having fun in a merry-go-round"<br /> clickurl="http://becominghmc.com"<br /> clicktarget="_blank"<br /> player="1"<br /> autoplay="false"<br /> loop="false"<br /> autorewind="true"<br /> /]</p> <p>I tried all the players but none of them are working at the moment?<br /> I also tried in side bar and used following code:</p> <p>&lt;?php<br /> if (function_exists('hana_flv_player_template_call')){<br /> $hana_arg="<br /> video='https://becoming.s3.amazonaws.com/teaser.flv'<br /> player='2'<br /> width='180'<br /> height='150'<br /> more_2=\"showStopButton: false, showScrubber: false, showVolumeSlider: false,showMuteVolumeButton: false,<br /> showFullScreenButton: false, showMenu: false, controlsOverVideo: 'locked',controlBarBackgroundColor: -1,<br /> controlBarGloss: 'none', usePlayOverlay:false \"<br /> ";<br /> echo hana_flv_player_template_call($hana_arg);<br /> }<br /> ?&gt; </p>