WP Marketing » Tag: javascript - Recent Posts http://wpmarketing.org/forum/tags/javascript Wordpress for Internet and Affiliate Marketing en-US Tue, 15 Jul 2014 09:43:48 +0000 http://bbpress.org/?v=1.0.2 <![CDATA[Search]]> q http://wpmarketing.org/forum/search.php hanadaddy on "Hana FLV Player not working with Thesis 1.7" http://wpmarketing.org/forum/topic/hana-flv-player-not-working-with-thesis-17#post-152 Sat, 17 Apr 2010 17:57:36 +0000 hanadaddy 152@http://wpmarketing.org/forum/ <p>Hello all,</p> <p>My plugin dose not use wp_head hook. It's hard to tell what causes the problem. I don't have the Thesis 1.7, so I can't test it either.</p> <p>Often the javascript is the source of the problem. If necessary javascript is not loaded properly, flash video player does not work.</p> <p>Also if you load multiple flash video players in the same web page, the javascript functions may interfere with each other( for example, same function names) that they prevent the proper working.</p> <p>If you post a link to your wordpress page that the player doesn't work and I will take a look at it.</p> <p>Also, I found that there is a problem when you use player 4 and player 2 in a same page. </p> <p>Thanks </p> noellyons on "Hana FLV Player not working with Thesis 1.7" http://wpmarketing.org/forum/topic/hana-flv-player-not-working-with-thesis-17#post-142 Mon, 12 Apr 2010 14:38:40 +0000 noellyons 142@http://wpmarketing.org/forum/ <p>Chris at Thesis was quick to reply:</p> <p>Basically, a .flv plugin needs at least one file in order to work, and that's a swfobject.js file in the document &lt;head&gt; (I've heard reports that these plugins don't work if the JS is embedded just before the end of the HTML document, which is generally where you want to place JS).</p> <p>With the plugin active, check out the content of the document &lt;head&gt; while using the default WordPress theme. Then for comparison's sake, activate Thesis, and see if the plugin is serving the necessary files in the &lt;head&gt;. If it's NOT, then you know what the problem is.</p> <p>Quite frankly, I don't see any good reason (from a coding standpoint, at least) why the plugin would work with 1.6 and then not with 1.7, but then again, plugin developers do some interesting things to initialize their code. The presence of the wp_head action call in Thesis 1.7 is enough to allow the plugin to initialize itself in the preferred manner, so as far as I'm concerned, there's no reason why it shouldn't work.</p> <p>If you do discover that the Hana FLV plugin is not being initialized properly with Thesis 1.7, you can either dig through the plugin yourself and try to get it to initialize on the wp_head action hook, or else you can contact the plugin developer and suggest that he/she initialize the plugin with this standardized action hook (wp_head).</p> <p>Finally, some developers test for the presence of the wp_head action hook in the theme's header.php file before initializing their code, and this is both archaic and unnecessary. If the Hana FLV developer has gone this route, then it's time for he/she to remove that archaic check, as the wp_head action hook does not, as a rule, have to exist in that file in order to function. </p> noellyons on "Hana FLV Player not working with Thesis 1.7" http://wpmarketing.org/forum/topic/hana-flv-player-not-working-with-thesis-17#post-141 Sun, 11 Apr 2010 06:52:59 +0000 noellyons 141@http://wpmarketing.org/forum/ <p>Me too Jordan, that may explain why it was working and now no longer is!</p> <p>Noel Lyons. </p> jordan123 on "Hana FLV Player not working with Thesis 1.7" http://wpmarketing.org/forum/topic/hana-flv-player-not-working-with-thesis-17#post-139 Wed, 31 Mar 2010 18:45:30 +0000 jordan123 139@http://wpmarketing.org/forum/ <p>Hey there,</p> <p>I've been using Hana FLV Player with Thesis Theme 1.6 for a while now, and it works great =)</p> <p>BUT... I upgraded to Thesis 1.7 yesterday and now my videos are not loading. Just a blank white space where the video would normally appear.</p> <p>Any ideas? </p> <p>Thanks. </p> volderette on "Only Player 3 works" http://wpmarketing.org/forum/topic/only-player-3-works#post-121 Wed, 03 Feb 2010 05:05:56 +0000 volderette 121@http://wpmarketing.org/forum/ <p>Hi, i finally found the solution. It has something to do with my functions.php which is from this theme: <a href="http://code.google.com/p/wp-basis-theme/" rel="nofollow">http://code.google.com/p/wp-basis-theme/</a> Now ive deleted the content of functions.php it works like charm.<br /> Thanks for your fast support! Keep up the good work!</p> <p>volderette </p> hanadaddy on "Only Player 3 works" http://wpmarketing.org/forum/topic/only-player-3-works#post-120 Tue, 02 Feb 2010 16:58:24 +0000 hanadaddy 120@http://wpmarketing.org/forum/ <p>Hi, There is nothing wrong with the short code.</p> <p>When I checked your web page's source code, I noticed there aren't any javascript tag showing. Javascript tag is used to show Flash player, so they are absolutely required.</p> <p>As I remember, some security plugin remove javascript tag from the post content. That's why I suspected you may have such plugin turned on. </p> <p>Why don't you set up a new wordpress in a separate folder and try out Hana Flv Player ? That will confirm if my assumption is correct or not.</p> <p>Here is the HTML source code of your page</p> <pre> &lt;html&gt; &lt;head&gt; &lt;meta name='robots' content='noindex,nofollow' /&gt; &lt;link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.pixel2motion.de/wordpress/xmlrpc.php?rsd" /&gt; &lt;link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.pixel2motion.de/wordpress/wp-includes/wlwmanifest.xml" /&gt; &lt;link rel='index' title='Pixel2Motion' href='http://www.pixel2motion.de/wordpress' /&gt; &lt;link rel='start' title='Die Entdeckung der Currywurst // DVD-Authoring // Kunde: Legend Home Entertainment // Januar 2010' href='http://www.pixel2motion.de/wordpress/feature-1' /&gt; &lt;link rel='prev' title='asdf' href='http://www.pixel2motion.de/wordpress/asdf' /&gt; &lt;link rel='next' title='asdf' href='http://www.pixel2motion.de/wordpress/asdf-2' /&gt; &lt;meta name="generator" content="WordPress 2.9.1" /&gt; &lt;link rel='canonical' href='http://www.pixel2motion.de/wordpress/sdafsdaf' /&gt; &lt;/head&gt; &lt;body&gt; &lt;h2&gt;sdafsdaf&lt;/h2&gt; &lt;p&gt; &lt;div &gt; &lt;div id='hana_flv_flow_1'&gt;&lt;/div&gt; &lt;/div&gt; &lt;/p&gt; &lt;/body&gt; &lt;/html&gt; </pre> volderette on "Only Player 3 works" http://wpmarketing.org/forum/topic/only-player-3-works#post-119 Tue, 02 Feb 2010 15:17:28 +0000 volderette 119@http://wpmarketing.org/forum/ <p>Hmm really strange. Thanks for trying that.</p> <p><code>[hana-flv-player video="http://wpmarketing.org/wp-content/plugins/hana-flv-player/babyhana.flv" /]</code><br /> The last code ive tried was this. I tried different versions though. Also with a local flv file.<br /> I had wordpress security scanner enabled but i turned it off when it hana-flv didnt work. </p> hanadaddy on "Only Player 3 works" http://wpmarketing.org/forum/topic/only-player-3-works#post-118 Tue, 02 Feb 2010 13:21:41 +0000 hanadaddy 118@http://wpmarketing.org/forum/ <p>I performed the testing with the Latest wordpress but was able to make it work with your single.php content.</p> <p>What was your short code used? Are you sure you are not using any security related plugins? </p> volderette on "Only Player 3 works" http://wpmarketing.org/forum/topic/only-player-3-works#post-117 Tue, 02 Feb 2010 12:44:08 +0000 volderette 117@http://wpmarketing.org/forum/ <p><code>&lt;html&gt;<br /> &lt;head&gt;<br /> &lt;?php wp_head(); ?&gt;<br /> &lt;/head&gt;<br /> &lt;body&gt;<br /> &lt;?php if (have_posts()) : while (have_posts()) : the_post(); ?&gt;</p> <p> &lt;h2&gt;&lt;?php the_title(); ?&gt;&lt;/h2&gt;</p> <p> &lt;?php the_content(); ?&gt;</p> <p> &lt;?php endwhile; else: ?&gt;</p> <p> &lt;p&gt;Sorry, no posts matched your criteria.&lt;/p&gt;</p> <p>&lt;?php endif; ?&gt;<br /> &lt;?php wp_footer(); ?&gt;<br /> &lt;/body&gt;<br /> &lt;/html&gt;</code></p> <p>This is my single.php. Very basic right now :-) </p> hanadaddy on "Only Player 3 works" http://wpmarketing.org/forum/topic/only-player-3-works#post-116 Tue, 02 Feb 2010 12:27:12 +0000 hanadaddy 116@http://wpmarketing.org/forum/ <p>Hello , </p> <p>Can you post the content of 'single.php' from your theme files? It's difficult for me to find where the problem is with the provided info.</p> <p>If you don't want it to post in the public, you can PM me. </p> volderette on "Only Player 3 works" http://wpmarketing.org/forum/topic/only-player-3-works#post-115 Tue, 02 Feb 2010 11:44:37 +0000 volderette 115@http://wpmarketing.org/forum/ <p>Hello, i have the same problem here. Only Player 3 works. I want to use Player 2 though. When i put it in directly in the template with hana_flv_player_template_call it works flawlessly. However when i want to insert a flv from a post it only gives me an empty div (<code>&lt;div id='hana_flv_flow_1'&gt;&lt;/div&gt;</code>). I deactivated all other plugins but its still not working. Im using the latest version (2.4.2) of your plugin and also the latest version of wordpress.<br /> The website is:<br /> <code><a href="http://www.pixel2motion.de/wordpress/sdafsdaf" rel="nofollow">http://www.pixel2motion.de/wordpress/sdafsdaf</a></code></p> <p>Thanks in advance,</p> <p>volderette </p> hanadaddy on "Only Player 3 works" http://wpmarketing.org/forum/topic/only-player-3-works#post-92 Wed, 30 Dec 2009 09:31:18 +0000 hanadaddy 92@http://wpmarketing.org/forum/ <p>Hello mjlady, I have seen similar cases that the javascript are being cut off by Wordpress or messed by other plugins. Please provide below information.</p> <p>URL to check out:<br /> Web Browser used:</p> <p>Thank you. </p> mjlady on "Only Player 3 works" http://wpmarketing.org/forum/topic/only-player-3-works#post-91 Mon, 28 Dec 2009 00:52:08 +0000 mjlady 91@http://wpmarketing.org/forum/ <p>Hi,</p> <p>In one of our site this plugin is working fine. But recently I added this to the new site and the video only shows when i choose player 3 (or maxi). And i suspect it may be a conflict on a plugin im using which like yapb (yet another photoblog)?</p> <p>thanks </p> focusedphil on "The Stop button" http://wpmarketing.org/forum/topic/the-stop-button#post-69 Tue, 17 Nov 2009 14:58:06 +0000 focusedphil 69@http://wpmarketing.org/forum/ <p>Great! thanks - good to know! </p> hanadaddy on "The Stop button" http://wpmarketing.org/forum/topic/the-stop-button#post-68 Sat, 14 Nov 2009 21:29:49 +0000 hanadaddy 68@http://wpmarketing.org/forum/ <p>I don't think it is possible to make this work using the default options provided with the included flash players. I think that this would be possible using the Flowplayer version 3 with its full support for <a href='http://flowplayer.org/documentation/api/clip.html' rel='nofollow'>javascript event support</a> , but there is just no simple way to do this.</p> <p>So basically you can not do this with Hana Flv Player. </p> focusedphil on "The Stop button" http://wpmarketing.org/forum/topic/the-stop-button#post-63 Thu, 12 Nov 2009 20:47:52 +0000 focusedphil 63@http://wpmarketing.org/forum/ <p>Hey - it's all working great in WP 2.8, just a small quibble - I can't seem to get the "stop" button to appear. When you click on the video playing it only pauses, is there anyway to have the click restore the thumbnail?</p> <p>Thanks </p>